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1 Scope and purpose 
User manual for VDR Explorer 

 

1.1 References 

DBS10956 Installation Manual for the DM100 VDR 

DBS10885 Installation Manual for the DM100 S-VDR 

DBS00238 Installation Manual for DM200/DM300 S-VDR and DM400/DM500 VDR 

MAN11841 Manual for Installation manual for Vessel Remote Server, VRS 002 

 

1.2 Terms and Abbreviations  

OPT Operational Performance Test  
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2 System overview 
The VDR Explorer is an application designed for XP or Windows 7. The VDR Explorer is able to 

replay data recorded by a DM100, DM200, DM300 S-VDR and DM100, DM400, DM500 VDR. 

The VDR Explorer can read data from the following sources: 

 

 

Source Description Hardware required 

Fixed capsule MK2 and MK3 

(capsules with Firewire 

interface) 

Data from the capsule which 

has been removed from the 

VDR 

- A PC with Firewire port. 

- Firewire repeater with CAT 5 

interface 

-  A mains to 12V DC adapter 

for the repeater is needed if a 

portable PC with 4-pin i/f is 

used 

Fixed MK4 capsule and float-

free MK1 (capsules with 

Ethernet interface) 

Data from the capsule which 

has been removed from the 

VDR 

- A PC with an Ethernet port. 

- A mains to 12V DC adapter  

- Power junction box p/n 

1302983 

DM300/DM500 VDR data disk  

(the removable hard drive) 

Data from a backup disk that 

has been removed from the 

VDR (Note 1)  

- A stationary PC with a 6-pin 

Firewire port. 

- A Firewire repeater and a 

mains to 12V adapter is needed 

when a portable PC with a 4-pin 

Firewire port is used  

DM200/DM400 USB VDR data 

disk 

Data from a USB backup disk 

that has been removed from the 

VDR (Note 1) 

- A PC with a USB port 

Data from External Extended 

backup (NAS) 

 - A PC with an Ethernet port 

VDR Extraction A file with VDR data 

downloaded from the VDR, 

capsule or a backup disk. It may 

also be a selection of data from 

another extraction  

 

Live Data transferred live from the 

VDR while recording. 

PC with an Ethernet port 

(10/100baseT) 
Note 1) Data can be retrieved from a functional VDR with the VDR data disk in place utilizing the web extractor utility 

and a PC with an Internet browser/Ethernet port. This is the simplest way of getting access to the VDR data. 
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2.1 Connecting a PC to a MK4 fixed capsule 

 

 

 

 

 

 

 

 

2.2 Connection a PC to MK1 float free 

 

 

 

 

 

 

 

 

 

 

 

 

 

2.3 Connecting the PC to a MK2 and MK3 fixed capsule 

 

 

 

 

 

 
 
 

 

 

 

 

 

 

 

 
 

 

 

Stationary 

PC 
FW repeater 

CAT5 
P/N 1001162 

Firewire 
cable 

6pin - 6pin 

Crossed CAT5 

RJ45 – RJ45 
Note 2 

Note 2) if the original cable is attached to the capsule, then use a straight CAT5 cable and a RJ45 coupler. 

Firewire 
cable 

4pin - 6pin 

FW repeater 

CAT5 

P/N 1001162 

12VDC 

Portable 

PC 

Crossed CAT5 
RJ45 – RJ45 

Note 2 

Mains 

adaptor 
P/N 1001163 

 110-240VAC 

Note 2) if the original cable is attached to the capsule, then use a straight CAT5 cable and a RJ45 coupler. 

Ethernet 

cable 
Power 
junction box 

P/N 1302983 

 
 

24VDC 

 

PC with 

VDR 

explorer 
 

Mains 

adaptor  110-240VAC 

 

Ethernet 

cable 
Power 

junction box 

P/N 1302983 

 
 

24VDC 

 

PC with 
VDR 

explorer 

Mains 

adaptor  110-240VAC 

 

Junction box 

2302868-10 
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2.4 Connecting the PC to a VDR data disk (DM300/DM500) 

 

 

 

 

 
 

 

 

 

 

 

 

 

Stationary 

PC 
Backup disc 

Firewire 
cable 

6pin - 6pin 

Firewire 

cable 
4pin - 6pin 

FW repeater 

CAT5  
P/N 1001162 

12VDC 

Portable 

PC 

Mains 
adaptor 

P/N 1001163 

 110-240VAC 

Backup disc 

Firewire 
cable 

6pin - 6pin 

Note) if the PC is unable to power the disc then use a repeater with a mains adaptor, see below. 
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3 GUI description 
 

3.1 After startup 

The VDR Explorer will, after startup, use the default configuration. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The “window title bar” complies with the general standard for Microsoft GUI. The window title bar 

displays the name (if defined) of the current GUI configuration. 

 

 

VDR Explorer window dropdown menus: 

 

File->New: Creates a new (empty) VDR Explorer configuration 

 

File->Open: Opens an existing VDR Explorer configuration 

 

File->Save: Saves the current VDR Explorer configuration using the same name 

 

File->Save as: Saves the current VDR Explorer configuration using a new name 

 

File->Recent files: Short cuts to the 4 most recent configurations which have been opened or saved 

on the disk. Any configuration which has been temporarily downloaded, e.g. from a VDR while 

playing live, will not be included on the list. 

 

 

Player control area 

 

Tab pages 

Tool bar 

VDR Explorer window, dropdown menus (MS windows style) 

 

Vessel information 

Player control area 

Tab pages 

Player window dropdown menus (MS windows style) 

Tool bar 

 

Player status bar 

 

Vessel information 

Player control area 

Tab pages 

Player window dropdown menus (MS windows style) 

Tool bar 

 



User Manual for VDR Explorer for DM100/DM200/DM300 S-VDR and DM100/DM400/DM500 VDR 

Danelec Marine A/S 

 

9200294-34  Page 13/108 

 

File->Exit: Exits the VDR Explorer program. 

 

View->Play control: Displays or hides the play control area. 

 

View->Vessel information: Displays or hides the additional vessel information. 

 

Tools->Log: Displays the log for the VDR Explorer program. This is only used for troubleshooting. 

 

Tools->Audio: Opens the audio settings dialog box. 

 

Tools->Alarm Display: Opens the alarm display window see section 18 

 

Tools->Connect: Opens the “connect” dialog box. The “connect” dialog box is used to select a data 

source for the VDR Explorer see section 12. 

 

Tools->Disconnect: Disconnects the VDR Explorer from the data source. 

 

Tools->VDR config management: The VDR Explorer is able to use information from VDR 

configuration object labels see section 11.1. 

 

Tools->VDR Explorer config management: The VDR Explorer is able to store its configuration 

together with source data and later retrieve this information see section 11.2 

 

Tools->Decoder library: Opens the NMEA decoder library, see section 13. 

 

Tools->Extractor: Opens the Extractor dialog box, see section 14.  

 

Tools->Export Data: Opens the Export Data dialog box, see section 15. 

 

Tools->Setup Serial Output: Opens a dialog box for selecting data to be outputted to other 

applications, see section 19. (This is only selectable when VDR Explorer is in configuration mode.) 

 

Tools->Setup AIS Data Input: Opens a dialog box for selecting the common data source for the 

AIS display objects, see section 8.2. (This is only selectable when VDR Explorer is in configuration 

mode.) 

 

Tools->Setup Alert Management Input: Opens a dialog box for selecting the data sources for the 

objects related to showing Bridge Alert Management data, see section 9 

 

Tools->Download from Ethernet capsule / float-free: Tools for downloading data from the MK4 

fixed capsule and the MK1 float-free i.e. the capsules utilized with the DM100 VDR or DM100 S-

VDR. 

 

Tools->VDR Data Download: Tool for downloading data from the VDR. VDR 

username/password for “superuser” or “svdr” can be used. In addition see Options->Preferences 

->Download settings.  The destination directory is defined under Options->Preferences->Directory 

settings-> Select VDR extractions folder. 
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Options->Color Definitions: Opens the definitions dialog box, see section 5.10. 

 

Options->Preferences: Opens the dialog box for setting the program preferences. 

 

Mode->Configuration mode - On: Sets the VDR Explorer to configuration mode. 

 

Mode->Configuration mode - Off: Exits the VDR Explorer from configuration mode. 

 

Monitor:  Queue monitor used for troubleshooting only. 

3.1.1 Tool bar 

The tool bar contains short cuts (presented as icons) to the most common tools and functions. 

3.1.2 VDR Explorer status bar 

The VDR Explorer status bar contains information regarding the current status of the VDR 

Explorer. Additional information regarding an object selected by the cursor (“on hover”) may be 

displayed to the left. 

 

3.1.3 VDR Explorer play control area 

The VDR Explorer play control area contains the main controls; i.e. play, stop and pause. Some of 

the controls will be grayed out depending on the data source for the VDR Explorer. See also section 

4.1.1 
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4 Replay of data, short guide 
 

The VDR Explorer automatically displays the “Connect” dialog box when the program is started. 

This dialog is used for selecting a data source. 

 

 
 

To select a data source press “Connect”, consult section 12 for more details. 

 

 

 
 

A VDR explorer configuration which matches the VDR data must be uploaded to the VDR when 

the VDR is installed. This will enable any PC with the VDR Explorer installed to replay data 

without any configuration work. If this dialog box appears then select, “Yes”. 
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4.1.1 Play control 

The play control area contains the functions needed for replaying data. Two views are available, 

simple and advanced. 

 

  
Simple play control 

 

 
Advanced play control 

 

A tool tip with helpful information appears if the cursor hovers over a bottom for short period. 

Note) The tool tip is not available for disabled functions (buttons with gray symbols). 

 

4.1.2 Tracks 

A track is defined as an uninterrupted recording session. The VDR will create a new track if it is 

restarted. VDR data retrieved from a normally operating VDR will only contain one track. Please 

note that the VDR Explorer will split a track downloaded from the VDR if a bad section of data is 

detected and for a DM100 VDR, if the VDR was reconfigured during the recording of the track. 

 

4.1.2.1 Goto button 

The “Goto” button will, if activated, set the slider to the position indicated in the input field below 

the button. A new value may be entered into the input field. The field will become red if the entered 

value is illegal or out of range. The icon to left of the “Goto” button may be used to update the input 

field with the current position of the slider. This function may be used while the VDR Explorer is 

replaying data. If you want to set a “mark” at an event you want to return to, do the following. First 

click on the icon (to the left of the “Goto” button) to set the “mark”, later you may click on the Goto 

button and then “Play”. 

4.1.2.2 Action at end of track 

It is possible to do one of the following when the end of the track is reached. 

 

Stop Stop playing  

Continue Continue to next track if present  

Repeat 1 Repeat current track  

Repeat All Continue to next track if present or replay track 1. 

 

 

Click here to expand the play control 
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5 Configuration 

The VDR Explorer must be in configuration mode  

“Mode->Configuration Mode - On” before any change of configuration can be made. 

5.1 Creating a new configuration 

File->New 

Creates a new “empty” configuration. 

 

File->Open 

Opens an existing configuration, e.g. a template. Use “File-Save as” to store the new configuration 

under another name. 

 

5.2 Adding new tab pages 

Right click on a tab for an existing page and then click on “Tab properties” and “Tab page 

organizer” will appear. 
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5.2.1 Tab page organizer 

 
The Tab page organizer 

 

The “Tab page organizer” is a tool for creating, deleting, naming, hiding and sorting the tab pages. 

 

Click on “Add” and this menu will appear 

 
Type in the title for the new tab page, select a template from the list box and click on “OK”.  
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5.3 Importing tab pages 

Right click on a tab for an existing page and then click on “Import Tab Pages”. This function is 

typically used for importing tab pages generated by the “VDR Explorer Configuration Creator” 

tool. It will import all tab pages from a VDR Explorer configuration into the current configuration. 
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5.4 Creating and moving graphical objects 

The graphical objects on a tab page are organized into panels (columns). A graphical object often 

contains many elements known as “gauges”. 

 

A proper tab page must be created before any graphical object can be created. Templates with one 

to four panels and one example have been made. (Right click on any tab for a tab page and then 

select ”Tab properties” to open the ”Tab Page Organizer” see section 5.2.  

 

A new graphical object is created on a panel by right-clicking on a panel, and then “Insert Object”.  

More objects within a panel will form a column. 

 

The position of an object within a panel may be moved up or down: Right click on the object and 

then click on “Object…-> Move up” or “Object…->Move down” 

 

A graphical object cannot be moved to another panel on the left or right. However, there is a way 

around this: 

 

1. Create a new instance of the object in the other panel.  

2. Copy the configuration from the original object and paste it onto the new object (see section 

5.5.1). 

3. Delete the original object. 

5.4.1 Creating and moving panels 

Right-clicking on an existing panel and selecting “Insert Panel” will create an additional panel. 

More features for manipulating panels are found by right clicking on an existing panel and then 

selecting “Panel Properties”  

5.5  Configuration of graphical objects 

A graphical object contains one or more gauges for displaying data. The only exceptions are the 

“Numeric data display”, which contains 3 “objects” for displaying data in numerical form or as text, 

and the Paper strip object that is able to display serial data as text. 

 

The following graphical objects have been defined (consult section 8 for objects related to AIS data 

display and section 9 for object related to bridge alert management): 

 Dial meter 

 Dual dial meter 

 Four Vertical bars 

 Two Horizontal bars 

 Compass dial 

 Horizontal ruler 

 Doppler log indicator 

 Dual Rudder indicator 

 Graph 

 Roll and Pitch indicator 

 Azimuth thruster 

 Numeric data display 
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 Small numeric data display 

 Extra small numeric data display 

 Paper strip 

 Display source information 

 Image data 

 Image data with meta data 

 

Right-clicking on the object while the VDR Explorer is in configuration mode opens the object 

property dialog box. 

 

The first tab page called “General” contains the 

most common parameters for a graphical object. 

This page is slightly different for the “Numeric 

data display” see section 5.7. 

 

Title: Text that is common for the gauges 

displayed by the graphical object. 

 

Gauges: Checkboxes for enabling/disabling the 

display of gauges defined for that graphical object.  

 

Frame: The boundary of a graphical object is 

indicated (default) with four thin lines. A number 

of graphical objects may be grouped by removing 

the adjacent lines. This is purely a visual effect. A 

line may be disabled /enabled by double-clicking 

on its position on the squared symbol located in 

this section. 

 

Source labels: (dial meter object only):  

The label for the fields that displays the data in 

numeric form 

 

The remaining tab pages are used for configuring 

the gauges defined for the graphical object.  

 

5.5.1 Copy/paste of graphical object configuration 

The configuration from a graphical object may be copied and pasted onto another identical 

graphical object. 

 

Copy configuration: 

Right-click on the object and then click on “Copy Config”. 

 

Paste Configuration: 

Right-click on the other object, and then click on “Paste Configuration”. Note that both graphical 

objects must be identical. 
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5.6 Configuration of Gauges 

5.6.1  Dial meter 

5.6.1.1 Labels  

Dial Title: Text located above the dial meter. 

 

Unit: Text located inside the dial. 

 

Use Peak indicator and Peak timeout: 

The peak indicator shows the maximum reading 

for a specified time (peak timeout). This is useful 

when measuring wind speed for example. 

 

5.6.1.2 Scale  

This section contain the parameters for 

controlling the geometry and resolution of the dial 

Start value: The start value is the most 

counterclockwise point on the dial. 

End value: The end value is the most clockwise 

point on the dial. 

 

Format:  

This defines the format of the figures on the dial, 

see section 5.11. 

 

Show Mathematical Sign: 

This controls whether figures on the dial are 

displayed with a mathematical sign. 

 

Angle: 

Defines the extent of the dial. 

 

Rotation: 

The dial will by default (value “0”) be similar to a 

typical speedometer. The rotation may be 

changed by entering a value other than “0” in this 

field. 

 

Resolution: 

This controls the resolution of the dial. 
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5.6.1.3 Sources  

Primary: Input to the pointer for the dial meter. 

  

Secondary:  Input to the secondary indicator for the dial meter. The secondary indicator is shown 

as a small triangle. The secondary indicator is typically used for displaying the “commanded value” 

while the main indicator shows the actual value. 

 

The “setup” button opens a dial box where the source data can be defined, see section 5.9 

5.6.1.4 Colors 

This controls the appearance of the dial meter. The “set to default” button resets all the colors to the 

default settings (see section 5.10) 
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5.6.2 Vertical bar 

5.6.2.1  Labels 

A vertical bar has two labels at each end. One of 

them is typically used as a description while the 

other is for unit of measurement. 

 

5.6.2.2 Scale 

Start Value: 

The start value is at the bottom of the bar. 

 

End Value: 

 The end value is at the top of the bar. 

 

Mirror Horizontally: 

Two adjacent bars are (default) symmetrical 

instances i.e. bar 1, 2 and 3, 4 form pairs. This 

may be changed by checking “Mirror 

Horizontally” for bars with e.g. odd number. 

 

Format:  

Defines the format of the figures for the bar, see 

section 5.11. 

 

Show Mathematical Sign: 
This controls whether the figures for the scale are 

displayed with a mathematical sign. 

 

5.6.2.3 Sources 

Primary: 

Input to the main indicator for the bar. 

 

Secondary: 
Input to the secondary indicator for the object. 

The secondary indicator is shown as a small 

triangle. The secondary indicator is typically used 

for displaying the “commanded value”, while the 

bar shows the actual value 

 

5.6.2.4 Colors 

This controls the appearance of the bar object. The “set to default” button resets all the colors to the 

default settings (see section 5.10) 
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5.6.3 Horizontal bar 

 The parameters for the horizontal bar correspond 

to the parameters for the vertical bar. An extra 

label (middle) has been added. 
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5.6.4 Compass dial 

5.6.4.1 Scale 

Format: 
This defines the format of the figures on the 

compass dial, see section 5.11.  

 

5.6.4.2  Sources 

Primary: 
The primary data source controls the rotation of 

the compass dial. The typical input is “Heading”. 

 

Secondary: 

The secondary (optional) data source controls a 

small triangle circling the compass dial. The 

typical secondary input is “Commanded 

Heading”. 

  

5.6.4.3 Colors 

This controls the appearance of the compass dial. 

The “set default” button resets all the colors to the 

default settings (see section 5.10) 
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5.6.5 Horizontal ruler 

5.6.5.1  Labels 

A vertical bar has 6 labels.  

5.6.5.2 Scale 

Star value: 

The start value is the far left point of the ruler. 

 

End value: 

The end value is the far right point of the ruler. 

 

Format:  

This defines the format of the figures on the ruler, 

see section 5.11. 

 

Show Mathematical Sign: 

This controls whether the figures on the ruler are 

displayed with mathematical sign 

 

5.6.5.3 Sources 

Primary: 
Input to the primary indicator for the ruler. The 

main indicator is shown as a triangle above the 

ruler. 

 

Secondary:  

Input to the secondary indicator for the ruler. The 

secondary indicator is shown as a triangle below 

the ruler. The secondary indicator is typically 

used for displaying the “commanded value” while 

the primary indicator shows the actual value. 

 

5.6.5.4 Colors 

This controls the appearance of the ruler. The “set to default” button resets all the colors to the 

default settings (see section 5.10) 
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5.6.6 Doppler log 

5.6.6.1 Numeric Output 

Unit: 
Text displayed after numeric outputs e.g. Knt.  

 

Format:  

This defines the format of the numeric outputs, 

see section 5.11. 

 

Show Mathematical Sign: 

This controls whether the numeric outputs are 

displayed with a mathematical sign. 

5.6.6.2 Sources 

4 inputs may be applied to the Doppler log object: 

 

Longitudinal Speed: 

 Is shown as numeric data in the center of the 

object 

 

Stern Transverse Speed:  

Is shown as numeric data at top of the object. 

 

Aft Transverse speed: 

Is shown as numeric data at bottom of the object. 

 

Relative Wind Direction: 

Is shown as a triangle circling the center of the 

object. 

 

5.6.6.3 Colors 

This controls the appearance of the object. The 

“set to default” button resets all the colors to the 

default settings (see section 5.10) 
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5.6.7 Rudder indicator 

5.6.7.1 Labels 

Title: 

Text shown beneath the rudder indicator.  

5.6.7.2 Scale 

Rudder Max Angle:  
 This controls the extent of the dial for the rudder 

indicator.  It is recommended that a value equal to 

the maximum rudder angle for the vessel is used. 

 

Show Mathematical Sign: 

This controls whether figures on the dial are 

displayed with a mathematical sign. 

 

5.6.7.3 Sources 

Primary: 
The primary data source controls the pointer; the 

typical input is data from the rudder angle sensor. 

 

Secondary: 

The secondary (optional) data source controls a 

small triangle circling the dial. The typical 

secondary input is “Commanded rudder angle”. 

 

5.6.7.4 Colors 

This controls the appearance of the rudder 

indicator. The “set to default” button resets all the colors to the default settings (see section 5.10) 
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5.6.8 Graph 

5.6.8.1 Graph type 

This section defines the input to the X-coordinate 

for the graph object.  

 

Time/Y graphs: 
The primary and secondary inputs are used for 

Y-coordinates for two independent graphs. Time 

is used as X-coordinate for both graphs. 

 

X/Y graph: The primary input is used for the X-

coordinate and the secondary for the Y-

coordinate. 

 

5.6.8.2  Resolution 

This defines the resolution of the graph(s). Small 

values for “Time Span” and “Sample Interval” 

give a graph with high resolution while high 

values give a graph that covers a large time span. 

5.6.8.3 Labels 

Label: 
Labels for the numeric outputs. 

 

Unit: 
Text displayed after the numeric output and as 

unit for the corresponding axis 

5.6.8.4 Scale 

This defines resolution and format of figures for 

the corresponding axis.  

5.6.8.5 Colors 

This controls the colors of the graph. The “set to 

default” button resets all the colors to the default 

settings (see section 5.10) 
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5.6.9 Roll and pitch indicator 

5.6.9.1 Gauge 

Title: 

Text shown above the gauge. 

 

Type: 
Used to select the gauge type (roll or pitch). Roll 

is default for gauge 1 and pitch is default for 

gauge 2 

5.6.9.2 Scale 

Format:  

This defines the format of the numeric outputs, 

see section 5.11. 

 

Show Mathematical Sign: 

This controls whether the figures on the dial are 

displayed with mathematical sign 

 

5.6.9.3 Source 

The data source controls the rotation of the ship- 

shaped indicator in the middle of the gauge; the 

typical input is data from the roll and pitch sensor 

respectively. 

 

5.6.9.4 Colors 

This controls the appearance of the object. The 

“Set to Default” button resets all the colors to the 

default settings (see section 5.10) 
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5.6.10 Azimuth Thruster 

5.6.10.1 Parameters for vertical bar 

The azimuth thruster object includes a vertical bar 

to the left. The parameters for this gauge are 

described in section 5.6.2 

5.6.10.2 Thruster 

Title: Text located over the dial and the alpha 

numeric field located top right. 

 

Unit: 

Unit for the alpha numeric field located top right.  

 

Use Sin/Cos input: 

Mark the checkbox if the thruster utilizes a 

sine/cosine interface for signaling the angle of 

thrust  

 

Rotation: 

Controls the orientation of the dial 

 

Scale: 
Scale may be set to either 0-360º or -180º to 180º. 

 

Scale resolution: 

This controls the resolution of the dial. 

 

Format:  

This defines the format of the figures in the alpha 

numeric field located top right, see section 5.11. 

 

Show Mathematical Sign: 

This controls whether figures on the dial are 

displayed with a mathematical sign. 

 

5.6.10.3 RPM 

This contains the parameters for the alpha 

numeric field located left center. 

5.6.10.4 Order 

This contains the parameters for the alpha numeric field located left bottom. 
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5.6.10.5 Sources 

This defines the input(s) to the thruster symbol and the two alpha numeric fields “RPM” and 

“Command”.  

5.6.10.6 Colors 

This controls the appearance of the thruster symbol and the two alpha numeric fields “RPM” and 

“Command”. The “Set to Default” button resets all the colors to the default settings (see section 

5.10) 
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5.7 Numeric data display 

5.7.1 General 

The Numeric Data Display does not display any 

gauges. Three smaller “objects” for displaying 

numeric data or text are displayed instead. These 

smaller “objects” are called “Alphanumeric data 

fields. Two sizes exist (large and small).  

5.7.2 Colors 

The color of the label text for a “Numeric data 

display” is determined by the default color 

definition (Text/Outline Color) see section 5.10. 

The “Primary indicator color” is used as color for 

the displayed data. 

5.7.3 Concatenation 

A number of Numeric Data Displays may be 

concatenated by removing adjacent lines (see 

section 5.5). 
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5.8 Paper strip 

The Paper strip object displays serial data as text 

e.g. data that is sent to a line printer. It can also 

be used to monitor NMEA data. 

 

5.8.1 Data format 

The object displays data using four different 

formats: 

 ASCII 

 NMEA 

 Binary. Binary is displayed as 

“hexadecimal” 

 Processed data 

 

“Processed data” in this context is typically data 

derived from NMEA strings using a decoder, for 

example vessel’s position. 

 

 

5.8.2 Channel 

This field is used for specifying the input to the 

paper strip object when data format is set to 

ASCII, NMEA or Binary. 

 

5.8.3 Source 

This field is used for specifying the input to the 

paper strip object when data format is set to 

“Processed data”. See section 5.9 for details. 

 

5.8.4 Output only changes 

A new line will not be printed unless data 

changes if the box is checked. 
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5.9 Configuration of data sources for objects 

This dialog box is common for all gauges and for the alphanumeric data display with a few 

exceptions. This box is opened by clicking on the “Setup” button in the “Source” section on the 

property pages for an object. 

 

 
Dialog for gauges 

 

 
Dialog for alphanumeric data display, use value 

 

5.9.1 Source 

Used for selecting a source for the gauge. A gauge/data field may be disabled by selecting “No 

Source” but the other parameters will not be forgotten if already configured. 
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For an “alphanumeric data field” the decoder output preference may be selected i.e. whether the 

output value or the text output must be used and displayed. The dialog will change accordingly. It is 

for example not possible to make calculation on the text output. 

 

5.9.1.1 Add to log (alphanumeric data field only) 

The information displayed in the data field will also be added to the log if this box is checked (see 

section 17). 

 

5.9.2 Display format (alphanumeric data field - use value and analog data) 

 
The parameters on this tab are used for formatting analog data or the value output from a decoder.   

 

5.9.2.1 Heading and trailing text: 

Heading and trailing text may be configured to change according to the numeric value of the data.  

5.9.2.2 Formatter string 

See section 5.11. 

5.9.2.3 Test data format 

A “test utility” is located beneath the configuration fields. 
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5.9.3 Display format (alphanumeric data field - digital data) 

 

5.9.3.1 Use text from VDR configuration 

This defines what text is associated to active and inactive state e.g. “Open” and “Closed”. This 

information is normally available from the VDR configuration and can be used by the VDR 

Explorer as it is.  

 

5.9.4 Field colors (alphanumeric data field only) 

 
 

Background color for an alphanumeric data field may be configured to change depending on the 

displayed value, for example green for indicating SB and red for indication PS. 
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5.9.5 Decoding (serial data only) 

 
 

Edit: Open the decoder script editor, see section 13.3. The editor is used for creating a new decoder 

script or for editing the currently selected one. It is strongly recommended that an edited decoder 

always be given a new name and that the modification is described. 

 

Save in library:  
Saves the decoder script in the library if it has been changed. See section 5.9.5.1 

 

Library: 
Opens the decoder script library from where the most commonly used decoder scripts can be 

selected. See section 13. 

 

Use checksum: 

NMEA strings not containing correct checksum information will be ignored if this box is checked. 

 

Use timeout: 

If this box is checked, the appearance of gauge/data field will be affected when no new data is 

received within a specified time period. 

 

- For gauges: 

The indicator will disappear. 

 

- For alphanumeric data field: 

An additional menu “Action” is displayed for an alphanumeric data field. 

The following actions are implemented: 

 Delete data: The data field is blanked 

 Dimming: Dimming of the text in the data field 

 Timeout: “Timeout” will be displayed in the data field 
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5.9.5.1 Relation between decoders stored in the library and the configuration 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 1) Decoder #2 is selected for Gauge #1 

Step 2) Decoder #3 is selected for Gauge #2 

Step 3) Decoder #4 is selected for Gauge #3 

Step 4) the decoder for gauge #3 is modified for some reason.  

There are now two options: 

Step 5a) Store the new decoder under a new name in the library; i.e. use the “Save library” function 

see section 5.9.5 

Step 5b) leave as it is; i.e. a new decoder is created but is not stored in the library.  

 

This message will appear if attempting to replace a decoder in a VDR Explorer configuration that is 

not stored in the library.  

 
 

Decoder Library 

Decoder #1 

Decoder #3 

Decoder #n 

Decoder #4 

VDR Explorer 

Configuration 

Decoder #2 

Gauge #1: 

Copy of 

Decoder #3 

Gauge #2: 

Copy of 

Decoder #2 

Gauge #3: 

1 

2 

4 Edited copy of 

Decoder #4 New decoder 

. 

. 

. 

. 

. 

. 

3 

5a 



User Manual for VDR Explorer for DM100/DM200/DM300 S-VDR and DM100/DM400/DM500 VDR 

Danelec Marine A/S 

 

9200294-34  Page 41/108 

 

5.9.6 Alarm display tab 

See section 18.3. 

 

5.9.7 Calibration tab 

See section 6. 

 

5.9.8 OPT format tab 

See section 7. 

 

5.9.9 Telemetry tab 

See section 22. 
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5.10  Default color definition 

 

 
 

The global colors define the overall color-scheme used for the graphical data display(s). 

 The background color is the color of the window used for graphical data display. The 

background color will be visible because there is a small space between objects (unless they 

are merged). 

 The Object Frame Color is the border of an object. 

 Object background Color is the background color used for objects. 

 “Text/outline color” is the color for static text (e.g. labels) and for the outline of most 

gauges. 

 

Changes to Global color take effect immediately after “OK” or “Apply” is selected, even when the 

VDR Explorer is not in configuration mode. 

 

The default colors are the colors of dynamic elements in a graphical data display, e.g. the indicator 

for a dial meter. Changes to default colors will only take effect for new objects. The colors for an 

existing object may be set to new default colors by right-clicking on the object (in configuration 

mode) and select Object->Set to Default Colors. 
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5.11  Formatter syntax 

Figures displayed in an alphanumeric data field may be formatted; i.e. the number of digits after the 

decimal point and leading zeros may be defined.  

 

The formatter syntax is identical to the syntax defined for formatting output from a NMEA decoder. 

 

E.g.: The figures 7.5 and 10 will be displayed as below, depending on the formatter. 

 

Formatter 7.5 10 

0 7 10 

0.0 7.5 10.0 

000 007 010 
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6 Calibration of data 
Analog data and values derived from NMEA sentences/Modbus may have to be calibrated before 

the data are meaningful. For example, rudder angle must be displayed as an angle corresponding to 

the angle of the rudder and not a value ranging from, for example, 0-4095. 

 

The requirements for calibrating data are described in the VDR standard. Data must be meaningful 

when replaying data and when examining the result of an OPT. 

 

Data may be calibrated in four different ways: 

 

 Analog data captured using a SIU may be calibrated via the VDR’s configuration interface. 

Until the release of VDR Explorer 3.42 this was the only option and the APT tool would list 

and error data was calibrated using this method. APT tool version 1.60 will just issue a 

warning since another option for calibrating data exist. 

 

 A value derived from an NMEA sentence/Modbus may be calibrated by including 

calculations in the decoder script (using the Calc statement). 

 

 A calibration may be included in the configuration for an object (Use Factor Offset) 

 

 A two point calibration made using the GUI of the VDR explorer.  This way of calibration 

the data will be described in this section. 
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6.1 VDR Explorer calibration mode 

In the example below calibration of a rudder system is shown: 

 

1) Create the required objects and decoder script and start playing live data. 

2) Turn the rudder 20 degrees to STP 

 

 
 

 
Enter calibartion mode 

 

 
Right click on object and select an item to calibrate and click “Calibration point 1” 
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Enter the value 20 (since the rudder was turned 20 degrees). 

Repeat that for the remaining three items. 

 

Turn the rudder 20 degrees to PS and enter -20 for calibration point 2 for all items 
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Check that the rudder angle is displayed correctly.  

 

 

 
Exit calibration mode and save the configuration. 
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6.2 Manually calibration using the configuration for an object 

 

Calibration data may be included in the configuration for an object. 

 

6.2.1 Calibration tab for analog data and value from serial data 

 

 
 

6.2.1.1 Use replay calibration  

The object will display the “raw” data if the check box is unchecked 

 

6.2.1.2 Use factor offset 

A factor (multiplier) and offset may be applied to the original data. E.g. knots may be converted to 

m/s. 

 

6.2.1.3 Used two-point calibration  

Data may be calibrated using the GUI as described in section 6.1. 
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6.2.2 Calibration tab for digital data (gauge only) 

 
 

6.2.2.1 Use alternative values (gauge only) 

Used to define alternative numeric values for active and inactive state, default (if box is unchecked) is 1 

and 0. 
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7 OPT Operational Performance Test 
It is a requirement of the VDR standard that data must be meaningful (calibrated values with 

engineering units) when replaying data and when examining the result of an OPT. 

 

An OPT must be carried out regularly be the crew. An OPT is initiated from the BCP and the result 

is displayed on the BCP also. A complete VDR Explorer configuration must contain the 

configuration for both the OPT and for replaying data. 

 

A VDR Explorer configuration for replying data are with few exceptions also adequate for the OPT. 

The differences are primarily related to the fact that the BCP cannot show gauges but only 

alphanumeric text. 

 

The OPT format tab on the page for setting the parameters for a source (see section 5.9) may be 

used for formatting the text in the OPT report. The VDR Explorer can in most cases format the text 

based on other parameters for the object. It will do that if “Use same output formatting as for 

display” is check-marked. 

 

 
OPT format tab for analog data and serial data, use value 
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OPT format tab for digital data (gauge only) 
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8 AIS data display 
There are eight objects for displaying AIS data: 

 

 AIS display 

 AIS display (small) 

 AIS own ship info 

 AIS target info 

 AIS target list (1x0.5) 

 AIS target list (2x0.5) 

 AIS target list (1x1) 

 AIS target list (2x1) 

 

The figures following an “AIS target list” refer to the size of the object where 1x1 is the typical size 

of a graphical object.  

 

Note that AIS data display object may be mixed with other objects on a tab page. 

 

8.1  AIS display tab 

A default AIS data display contains a useful combination of AIS objects. This tab page is created 

like any other tab page, see section 5.2. 
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The AIS tab page is composed of the following objects: 

 One AIS display 

 One AIS Own ship info 

 Four AIS target Info 

 One AIS target list (2x0.5) 

 

8.2  Selecting data source 

 

“Tools->Setup AIS Data Input” opens the “AIS data settings” tool. 

 

 

 
                                        AIS data settings 

 

Select the serial or network channel to which the AIS data is received from. 
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8.3  Using a AIS display tab 

 
 

The most important feature of the AIS data display is the ability to assign a label to and get 

information about a target of interest. This is done by clicking either directly on the target on the 

AIS display or on the label field for the target in the AIS target list. An AIS target info object will 

be assigned to the target when this is done.  

 

E.g.: On the AIS display tab shown above, targets “A” and “B” have been selected. 

 

A target may be deselected by clicking on the target again.  

 

8.4  Symbols for Targets 

 

AIS Standard target:  

 

Base station:   
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Aids to navigation:  

 

Aircraft:   

 

 

8.5  Supported messages 

1 - Position report  

2 - Position report  

3 - Position report  

4 - Base station report  

5 - Static and voyage related data  

6 - Binary addressed message  

8 - Binary broadcast message  

9 - Standard SAR aircraft position report  

12 - Addressed safety related message  

14 - Safety related broadcast message  

18 - Standard Class B equipment position report  

19 - Extended Class B equipment position report  

21 - Aids-to-navigation report  

22 - Channel management 

24 - Class B "CS" static data report 
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9 Display of data from vessel’s Alert Management System 
There are six objects for displaying bridge alert management data.  

 

Alert list (1x1) 

Alert list (2x1) 

Alert list (1x2) 

Alert list (2x2) 

Alert event log (1x1) 

Alert event log (2x1) 

 

The objects have been designed for showing data from an integrated bridge alert management 

system but may be used to display ALR messages in general. 

 

9.1 Alert List object 

An alert list object displays the status of the alerts which are currently active based on data received 

from the serial/network channels which have been associated with this functionality (see section 

9.3). 
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9.2 Alert event log object 

An alert event log object displays all events related to alarm message received from the 

serial/network channels which have been associated with this functionality (see section 9.3). 

 
 

 

9.3 Selecting data sources 

“Tools->Setup Alert Management Input” opens the “Alert management” tool. 
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10 Objects related to images received over IEC 61162-450 
The section is only relevant for the DM100 VDR. 

 

10.1 Object for showing “status and information text” 

Additional data, so-called “status and information text” are transmitted with images sent to the 

VDR using the IEC 61162-450 protocol. These data may be displayed using the “image data with 

meta data object” rather the normal “image data object” 

 

10.2 Object for showing “display source information” 

An ECDIS for example must, according the VDR standard, send “display source information” at a 

minimum every 10 minutes to the VDR.  For example, information about which chart is currently in 

use. 

 

A “Display source information object” may be used to show these data. 
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11 VDR and VDR Explorer configuration management 
The VDR Explorer uses information from both the VDR configuration (if available) and a VDR 

Explorer configuration. The VDR configuration contains useful information about what is 

connected to the VDR. Information from the VDR configuration may, for example, enable the VDR 

Explorer to use the name “SI02 Input from GPS” for serial input port #2 rather than just the default 

name “SI02”.  

These functions are normally not needed except for “Tools->VDR Explorer config management-> 

Save VDR Explorer-configuration to source”. This function is used for storing the final VDR 

Explorer configurations in the capsule. This will enable any PC with the VDR Explorer installed to 

replay data from that VDR correctly. In addition, the saved VDR Explorer-configuration is 

prerequisite for being able to perform an OPT. 

11.1 VDR configuration management 

Tools->VDR config management->Load VDR configuration from file 

Facilitates load of an alternative VDR configuration from a file. 

 

Tools->VDR config management->Load VDR configuration from source 

Reloads the original VDR configuration from the source. 

 

Tools->VDR config management->Set VDR configuration to default 

Restores the VDR configuration to default; i.e. all labels will then correspond to what is printed on 

the data interface modules e.g. “SI02”. 

 

Tools->VDR config management->Save VDR configuration from source to file  
Saves the VDR configuration present on the source to a file. 

 

Tools->VDR config management->Save VDR configuration from source to HTML file  
Saves the VDR configuration present on the source to an HTML file. 

 

Tools->VDR config management->Display VDR configuration from source 

Displays the VDR configuration found at the source to which the  

VDR Explorer is currently connected. 

11.2 VDR Explorer configuration management 

A few special commands related to VDR Explorer configuration management are included here. 

Commonly used commands like Open, Save etc. are included in the “File” dropdown menu. 

 

Tools->VDR Explorer config management-> Load VDR Explorer-configuration from source 

Tool for reloading of a VDR Explorer configuration from the data source 

1) VDR (live playing): The configuration stored in the capsule will be loaded. 

2) Capsule/backup disk: The configuration stored in the capsule/on the backup disk will be loaded. 

3) Extracted data: A dialog box enables the user to load the original. 

 

Tools->VDR Explorer config management-> Save VDR Explorer-configuration to source 
Tool for saving the VDR Explorer configuration at the data source. 
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1) VDR (live playing): The current VDR Explorer configuration is stored in the capsule and on the 

backup disk via the VDR. The VDR Explorer must be connected as “Master”. 

 

2) Capsule/backup disk: The VDR Explorer is not able to write to a capsule/backup disk and is 

consequently not able to save the VDR Explorer configuration at the source if data source is a 

capsule/backup disk 

 

3) Extracted data: The VDR Explorer is not able to write to an extraction is consequently not able to 

save the VDR Explorer configuration at the source if data source is an extraction. 
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12 Connect dialog box  
Tools->connect opens the “Connect” dialog box. 

 
 

The “Connect” dialog box is used for connecting the VDR Explorer to a data source. Four types of 

data sources are supported: 

 

 VDR extraction 

 Live from a VDR  

 A capsule (only MK2 and MK3) * 

 A backup disk 

 

The connect dialog box changes according to the selected type of data source.  
* Data from MK4 and MK1 float-free must be downloaded using Tools-> Download from Ethernet capsule / float-free 

12.1 Capsule 

“Capsules online” window: 

The “Capsules online” window displays a small symbol for each capsule which is physically 

connected to the VDR Explorer PC via the Firewire interface. A capsule is selected by left -clicking 

on its symbol. (Note: It is unusual to connect more the one capsule, but up to three capsules may be 

connected simultaneous if necessary) 

 

“Refresh” button: 

Forces the VDR Explorer to scan the Firewire for capsules and update the window.  

 

“Analyze” button and “track information” window: 

The selected capsule may be analyzed for its content. The result is displayed in the “track 

information window”. For more information about tracks, consult section 14.1.1 
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“Connect” button: 

Establishes a connection from the VDR Explorer software to the selected capsule. This may take a 

few seconds.  

 

“Cancel” 

Closes the window. 

12.2 Backup  

A disk that has been removed from a VDR 

 

The dialog for connecting a Backup Disk corresponds to the dialog for connecting a capsule, 

described in section 12.1. 

 

12.3 VDR extraction 

“Browse” button: 

Opens a standard file browser dialog box, which is used to locate and open a file containing a VDR 

extraction (file extension is .vee). 

 

“Analyze” button and “track information” window: 

The selected file may be analyzed for its content. The result is displayed in the “track information 

window”. For more information about tracks consult section 14.1.1. 

 

“Connect” button: 

Connects the VDR Explorer to the selected database.  

 

“Cancel” button: 

Closes the “Connect dialog” window. 

 

12.4 Live 

“Connect to IP” field:  

The IP address of the VDR must be entered here. 

 

“Get information” button: 

Tests the connection to the VDR with the IP address displayed in the “Connect to IP” field. Status 

information from the VDR will (if the tested VDR is online) be displayed in the VDR “Information 

field”.  

 

“Connect” button: 

Connects the VDR Explorer to a VDR with the IP address displayed in the “Connect to IP” field.  

 

“Cancel” button: 

Closes the “Connect dialog” window. 
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13 Decoder library 
The NMEA decoder library is used to organize the NMEA decoders. A NMEA decoder is a small 

script which describes how information is being decoded and retrieved from a specific NMEA 

sentence. The syntax for the script language is described in section 21. A short description is 

available under “Help->Help Topics” in the decoder editor.   

 

Tools->decoder library opens the decoder library. 

 

13.1 Properties for NMEA decoders 

 

Sentence formatter: 
An NMEA decoder is only able to retrieve information from one specific NMEA sentence. 

A typical NMEA decoder is only able to retrieve information from one field in an NMEA sentence. 

Most NMEA sentences contain many fields; so a number of decoders may be needed for retrieving 

all the information from one sentence.  

 

Decoder group: 

An NMEA decoder belongs to a group; all decoders in the same group are stored in the same folder.  

Groups have been defined corresponding to the data items to be recorded (IEC 61996 section 4.6), 

e.g. speed (4.6.3) or heading (4.6.4). The user may establish new groups. 
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Decoder name: 
A decoder must be assigned a name. The name must be unique within the decoder group. 

 

(Write) protected decoders: 

A number of standard decoders (protected decoders) have been defined. These decoders are write- 

protected and cannot be changed or deleted. However it is possible to use one of these decoders as a 

template for a new decoder. 

 

Sub-library file:  

The VDR Explorer at startup “compiles” the library from a number of library files each containing a 

number of decoders. The standard decoders are stored in one file and another file is used to store the 

user-defined decoders. More library files for specific purposes may be added. 

 

Decoder output: 

The output from a decoder may behave like analog data, digital data or a text string. This 

information may be described for a decoder. However, this information is only informative and will 

not be used by the VDR Explorer.  

 

13.2 NMEA decoder library window 

 

13.2.1 Drop down menus  

File->import: 

Imports decoders from an external file. The imported decoders will be added to the user-defined sub 

library file. 

 

File->export: 

Exports decoders to an external file. 

 

File->Save in library:  
Saves decoder in library. 

 

File->Close: 

Closes the window. Corresponds to cancel. 

 

Edit->New decoder: 

Adds a new decoder to the library. 

 

Edit->New folder: 

Adds a new folder to the library.  

 

Edit->Copy: 

Makes a copy of the selected decoder. 

 

Edit->Edit: 

Opens the decoder edit window. 
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Edit->Rename: 

Renames the selected decoder or folder. 

 

Edit->Delete: 

Deletes the selected decoder or folder. 

 

 

13.2.2 Decoder library tree 

The decoder library tree is shown to the left. The “radio buttons” at the top are used to define how 

the library is organized. 

 

A pop up menu appears if the you right click on a 

folder or a decoder. This menu enables you to add, 

rename, copy and delete folders and decoders.  

For “Import to Folder” consult section 13.2.1 

Note: It is only possible to create a new “root 

folder” by right-clicking on the empty space 

beneath the “library tree”. 

 

13.2.3 Decoder description 

The properties for the selected decoder are shown in decoder description located to the right in the 

NMEA decoder library window. Consult section 13.1 for more details. 

 

Pop up for decoder Pop up for folder 
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13.3 NMEA Decoder Editor 

The NMEA decoder editor may either be opened from the decoder library or from the settings menu 

for a gauge/alphanumeric data field. 

 

 

13.3.1 Drop down menus 

 

File->Save as 

Closes the editor window and opens the NMEA decoder library window where the new name and 

folder (group) may be defined. This item is only present if the editor is called from the NMEA 

decoder library. 

 

File->Close 

Closes the editor window. The user will be prompted for unsaved changes. 
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Edit->Undo 

Edit->Redo 

Edit->Cut 

Edit->Copy 

Edit->Paste 

Edit->Delete 

Commands for the Editor 

 

Tools->Insert symbol  
A menu with symbols normally not found on a keyboard will be displayed. 

 

Help->Help topics 
A description of the decoder script language will be displayed. 

13.3.2 Tool bar 

A tool bar is located below the drop down menus. The tool bar contains short cuts (icons) to the 

most commonly used items from the drop down menus. 

 

13.3.3 General buttons 

 

“OK” button: 

Changes made will be stored; the editor window is then closed. The previous version of the decoder 

is overwritten. It is not possible to overwrite the decoders that are supplied with the VDR Explorer. 

 

“Cancel” button: 

Closes the editor window. Any changes made will be ignored and lost. 

 

“Save As” button: 
The editor window will close. Changes may be saved using a new name/folder while maintaining 

the previous version of the decoder. 

The “Save As” button is only enabled if the editor window is opened from the library (i.e. disabled 

when opened from the GUI configurator).  

 

13.3.4 Decoder information 

 

Decoder name: 

See section 13.1  

 

Decoder output: 

See section 13.1  

 

Decoder description: 

A description of the decoder may be included (recommended). 
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13.3.5 Editor window 

A script defining the decoder must be entered in the NMEA decoder window. The “sentence 

formatter field” derives information from the “search for” statement in the decoder script. The full 

name for the NMEA sentence will be displayed if the sentence formatter is known. 

 

“Help->Help topics” shows a short description of the script language. Section 21 contains an 

extensive description of the script language. 

13.3.6 Decoder test 

A decoder may be tested against an NMEA sentence if the test decoder button is activated. Two 

things happen when the test button is activated: 

1. The script will be compiled; i.e. the syntax is checked. The text in the “NMEA test 

sentence” field will not influence this. The test will only continue if the compilation is 

successful. 

2. The NMEA decoder will decode the NMEA sentence shown in “NMEA test sentence” field. 

This is, of course, only meaningful if the NMEA sentence formatter in the test sentence 

matches the NMEA sentence formatter in the decoder’s “search for” statement. The data 

output and the trend output will be displayed upon a successful test. 

 

13.3.6.1 “NMEA test sentence” field 

A test sentence may be entered in this field. Copy/paste from, e.g. the serial monitor, may be used. 

The ten most recent test sentences will be saved. 
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14 Extractor 
The Extractor is used to retrieve data from a data source to a file. The VDR Explorer must be 

connected to a data source (not live from a VDR) before the Extractor tool can be opened. 

 

 

14.1.1 Track information 

The track information for the currently selected capsule or backup disk is displayed in this window. 

A track is defined as an uninterrupted recording session. This typically corresponds to a time period 

where the VDR was not interrupted, e.g. by a restart. However, other events may divide a recording 

into two tracks, e.g. a bad record (checksum error) on the disk or a VDR configuration change.  

 

One or more tracks must be selected before the extraction process can start.  The sliders on the blue 

bar may be used to reduce the amount of data used from the selected track.  
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Extraction options 
Only relevant for a DM100 VDR. Used for specifying how OPT data will be handled. 

 

Extraction target: 

Displays the currently selected (if any) target file for the extraction.  

 

“Extract” button: 

Starts the extraction process. 

 

“Close” button: 

Closes the window. 

 

 

Overview for the extraction process step by step: 

 

1. Connect to a capsule or backup disk using the connect tool. 

2. Open the extractor tool. 

3. Select and optionally shorten the duration of tracks to be extracted. 

4. Select how OPT data is to be handled (only DM100 VDR). 

5. Select (Browse) the target file for the extraction. 

6. Start extraction process using the “Extract” button. 

 

Extracting all data from a capsule takes approximately from 20 minutes to 2 hours depending on 

the size of the capsule.  
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15 Data Export Tool 
The “Data Export Tool” may be used for exporting the VDR data into either an IEC61996-1/2 

compatible format or an open industry format. 

 

Data IEC61996-1/2 format Open industry format  

Audio Wave files (*.wav) Wave files (*.wav)  

Images Bitmap (*.bmp)/PNG(*.png) Compressed Tiff (*.tif) 

PNG(*.png) 

 

Serial data One comma separated data file 

(*.txt) 

Text files (*.txt)  

Analog and Digital data Comma separated files (*.csv) Note 1 

Power status Comma separated files (*.csv) Note 1 

Alarms Text files (*.txt)  

System log Text files (*.txt) Text files (*.txt)  

Configuration HTML file (*.htm) HTML file (*.htm)  
Note 1) The separator will be “,” or “;” depending on the regional settings for the VDR Explorer (Options -> 

Preferences -> Regional Settings) 
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A data source must be selected before opening the export tool (see section 12). 

Click on “Tools -> Export data” and the data export tool dialog box opens. 

 

Select the data to be exported (checkmark all boxes if all data is to be exported). 

Select a folder for the data (Click on “Browse to folder”). 

 

Select whether the export format should be IEC61996-1/2 (“IMO mode” checked) or an alternative 

open industry (“IMO mode” not checked). For IMO mode is it possible to split the audio files, data 

file and the system log into smaller handier files, each covering a user-definable time span. 

 

Click on “Export”. 

15.1.1 Export raw serial data 

Time stamps for serial data will be omitted if “Export raw data” is selected (radio button to the 

right). Data from each serial channel will be exported to an individual file. 
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16 Audio settings tool 
Go to “Tools->Audio” 

 
 

The speaker symbols may be used (by left-clicking on them) for selecting and directing audio 

channels to the left or right speaker channel on the PC used for replaying. 

 

A master volume control is located to the right. 

 

The compression effect is useful when listening to recordings with a high dynamic range. 

 

16.1  Password protected audio 

Audio may be password protected i.e. replay of audio disabled unless the correct password is 

entered. Audio replay may be enabled by opening the Audio Settings Tool and entering the correct 

password when prompted. 

 

The password is defined by the configuration for the VDR. 
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17 Data Log 
The data log function is able to log data from selected objects into a CSV file. The data log function 

is associated with a special tab page. The data log tab page is created as any other tab page. 

 

 The VDR Explorer must be set in configuration mode. 

 Right click on a tab for a tab page and then select “tab properties”. This opens the “tab page 

organizer”. 

 Click on “add” and select the “Data Logger Tab”. 

 

17.1  Configuration of data log 

Columns may be created by two methods. 

 

17.1.1 Direct creations of columns 

 The VDR Explorer must be in configuration mode. 

 Right-click on the title bar for the columns next to “Timestamp”. 

 

 

 
 

 Click on “add column” and a list of relevant objects appear. 
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 Select an object and click on OK  

 

 

 
 Enter the title, click ok and a new column is created. 

 

 
 

 

 



User Manual for VDR Explorer for DM100/DM200/DM300 S-VDR and DM100/DM400/DM500 VDR 

Danelec Marine A/S 

 

9200294-34  Page 76/108 

 

17.1.2 Indirect creations of columns 

 

 The VDR Explorer must be in configuration mode. 

 Open the properties dialog for an object that is able to input data to the data log (short 

standard object and standard object) 

 

 
 

 Check “Add to log” and a new column is created. 

 

 

 
 

 Change the title if needed. Right-click on the column title, select “Column Title” and enter a 

new title. 
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17.1.3 Organizing columns 

The VDR Explorer must be (with a few exceptions) in configuration mode. 

 

Right-clicking on the title for column opens a menu with miscellaneous commands. 

 

In general the width and order of the column can be changed in the same manner as for many other 

Windows programs, e.g. using “click, drag and drop” on the column title can be used to rearrange 

columns. 

 

17.1.4 Maximum number of columns 

The maximum number of columns that can be handled depends on the PC. A PC that meets the 

general requirements for the VDR Explorer will be able to handle 25 columns without any 

noticeable performance degradation. 
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17.2  Saving log data to a file 

The program will store the data to a user-defined output file. 

 

 
  

 

 

The library path for the log files is defined by the preferences for the VDR Explorer. See section 

17.3 

 

17.2.1 Max file size 

Maximum file size is user-defined. Data logging will stop when the file is full. The file may then be 

reset (or renamed/moved using Windows Explorer). 

 

17.2.2 Sample interval 

The sample interval is user-defined. Fast sampling (small intervals) requires lot of disk space. 

 

 

17.3  Preferences 

17.3.1 Directory path for log files 

The library path for the log files is defined by the preferences for the VDR Explorer (VDR Explorer 

main window, Options->Preferences->Directory settings). 

 

17.3.2 Disable data logging at connect 

Data logging without explicit acceptance can be restricted (VDR Explorer main window:  Options-

>Preferences->Data Logger). 

 

On: Data logging must be started manually even if a VDR Explorer configuration with 

“data logger enable” is loaded. 

Off:  Data logging will start automatically if a VDR Explorer configuration with “data 

logger enable” is loaded. 

Prompt:  (Default) the user will be prompted for acceptance of data logging.  
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18  Alarm panel 
The Alarm panel is a tool which can be used for analyzing recorded and live data. It can be 

configure to generate an alarm if a specific event happens. 

 

Please notice, that the Alarm panel is not related to the objects for displaying data from the vessel’s 

alert management system (described in section 9). 

 

Selecting “Tools->Alarm Display” or clicking on the  icon on the Player window tool bar will 

activate the alarm window. 

 

 
 

 

Acknowledge all alarms: 

This function acknowledges all alarms on the list. An alarm may be acknowledged individually by 

clicking on the  icon for that alarm. 

 

Delete all alarms: 
The function deletes all alarms from the list. An alarm may be deleted individually by clicking on 

the  icon for that alarm. 

 

Acknowledge audio: 
This function mutes the audio until a new alarm is generated. 
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Options->Disable sound:  
This option mutes the audio related to the alarms panel completely. 

 

Options->Disable popup: 
This option prevents the alarm window from popping up when a new alarm is generated. 

18.1.1 Easy localization of alarms-source 

Double-clicking on the text for an alarm brings the tab page from where the alarm is generated to 

the front. 

18.2  Default setting for alarm panel 

The default settings for the alarm panel may be set from the Player’s main window by selecting 

“Option->Preferences”. 
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18.3  Configuration of objects for alarms 

Most objects can generate an alarm to the alarm panel. 

 

The parameters for generating alarms are located together with the other parameters related to a 

data source see section 5.9. 

  
 

The example above shows how an alarm will be generated if, for example, the wind speed is above 

23kts. 

 

Active: 

The object will only generate alarms if this box is checked. 

 

Alarm text: 
The text that will be written in the alarm window. 

 

Level Alarm: 
An alarm will be generated if the output is above or alternatively under a specific level. 

For serial communication, please note that the trend output from an NMEA decoder is used for the 

alarm system. 

 

Alarm on new data: 

An alarm will be generated every time data is received (only applicable for serial data).  
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19  Relay of serial output to other applications 
The VDR Explorer is able to relay serial data to other applications. 

 

19.1  Output port settings 

An output port on the PC for the serial data is needed and must be configured. These parameters are 

included in the VDR Explorer’s preferences (Options->Preference->Port Settings). 
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19.2  Configuration of serial output 

The VDR Explorer must be in configuration mode. 

A click on “Tools->Setup Serial Output” opens the tool for configuring the sources of the serial 

output. 

 

 
 

The number of data sources and the output port may be selected. 

 

19.2.1 Merging of data 

The program is designed to handle NMEA sentences; i.e. two sentences will not be interleaved but 

sent one at a time. The program may fail to relay ASCII or binary data correctly depending on the 

properties of the data. 

19.3  Enable/Disable output 

An icon on the VDR Explorer tool bar can be used to enable/disable the serial output. This can 

be done while the VDR Explorer is playing/replaying data. 
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19.4  Overflow on serial port 

The serial output port may overflow if the combined inputs exceed the capacity of the output port. 

The warning may be displayed if this happens. It is possible to suppress the message. This will be in 

force until output is disabled and then enabled. 

 

19.5  Serial output and step 

The VDR Explorer is able to generate serial output while stepping. However the output port may be 

congested and steps may take very long time to process.  
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20 Special features 

20.1  Floating windows 

Note: This new feature has been designed for experienced users. Using floating windows in 

configuration mode may be confusing. 

 

A tab page may be detached from the VDR Explorer’s main window.  This is either done by “click, 

drag and drop” or double-clicking on the tab for a tab page. 

 

Right-clicking on the top bar for a floating window opens a menu with items for manipulating the 

window, e.g. making it full screen. 

 

Double-clicking on the top bar for a floating window reverts the window to a tab page. A floating 

window will also revert to a tab page if the corner of the window is aligned with the corner of the 

first tab in the VDR Explorer’s main window.  

20.1.1 “Windows” dropdown menu  

A dropdown menu (Windows) has been added to the menu bar for the VDR Explorer’s main 

window. The window selected from this menu will be brought to the front. 

 

20.2  Support for PCs with lower screen resolution 

The VDR Explorer is designed for 1280x1024 and above, however a PC with lower screen 

resolution may be used with minor inconvenience. 

 

20.3  Vessel information 

Complete vessel information is normally not displayed. “View->Vessel information” may be used 

to open/close a window for displaying complete vessel information. 

One “data item” related to Vessel information (vessel name is default) is displayed next to the tool 

bar for the VDR Explorer’s main window. 

 

20.4  Play control 

“View->Play Control” may be used to hide/show the Play Control. The Play Control may also be 

moved around (click, drag and drop). 

 

20.5  Full screen radar image 

Full-screen radar image is entered and exited by double-clicking on the image. 

20.6  Full screen graph object 

A double-click on a graph object expands it to full-screen. A full-screen graph will return to normal 

size upon a double-click. 
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20.7 Full AIS display 

A double-click on an AIS display object expands it to full-screen. A full-screen AIS display object 

will return to normal size upon a double-click. 
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21 NMEA sentence formatting script language V3.0 

21.1  Purpose 

The purpose of this language is to easily match a given NMEA sentence and format it to human- 

readable text. This implies that both pattern matching ability and string formatting ability must be a 

part of the language. The resulting human-readable text will have a value associated with it. This 

value is used for the trend indicator and is most likely taken from the NMEA sentence. 

21.2  Language introduction 

Matching and formatting an NMEA sentence consists of applying a small compiled program to an 

NMEA sentence. The output from this program will be a formatted string and an optional value. In 

this context, a program is a compiled set of statements in the NMEA sentence formatting language. 

The source for a program in this language consists of a sequence of statements. Each statement will 

be executed in the order they are written; i.e. the language is a straight-line language. If a statement 

fails, the program will exit. 

21.3  Language example 

The syntax and semantics of the language is best shown by use of an example.  

The following NMEA sentence is to be formatted: 

Field no: |  1  |    2    |3|    4     |5|    6    | 7 

Sentence: $GPGLL,5536.1234,N,01244.1234,E,123456.78,A*1B 

into the following result: “N 55°36.123” and the associated trend value “5536.1234” . Running the 

following program does this: 

// This is a comment and have no effect on the program 

Search for “GLL” 

If #7 <> “A” 

   print “GPS failed” 

   Stop 

EndIf 

Print #3 

Print “ “ 

Print #2 1:2 

Print “°” 

Print #2 3:6 F00.000 

Trend #2 

The first line is a comment and has no effect on the program, but can be a useful aid when 

developing decoders in the formatting language. The second line “Search for “GLL”” identifies 

which NMEA id this program is valid for. The third line uses an “if“ construct to test if field 7 

contains the text “A”. If this is the case, the text “GPS failed” is printed and the program stops. If 
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not, the program continues onto line three. The next few lines consist of “print” statements on 

field identifiers and strings. The hash mark “#” indicates a field identifier: 

#field [range] [format] 

Where “field” indicates the field number, “range” the range of characters to use and “format” 

how the number should be formatted. 

Continuous “print” operations can be concatenated into one “print” sentence resulting in a more 

compact program: 

Search for “GLL” 

If #7 <> “A” 

  print “GPS failed” 

  Stop 

EndIf 

Print #3 “ “ #2 1:2 “°” #2 3:6 F00.000 

Trend #2 

The last line identifies the field which will be used as the trend value. 

21.4  Bit function examples 

The following fictive NMEA sentence is used: 

Field no: |  1  |    2     |3| 4 

Sentence: $XXYYY,DEADBEEF01,N,A*1B 

 

search for "YYY" 

 

if bit(#2,2) = 1 

    print "bit 2" 

    stop 

endif 

 

if bit(#2,1) = 1 

    print "bit 1" 

endif 

The output of this program applied to the above NMEA sentence is: “bit 1” since bit 2 is not set. Bit 

number is counted from the right hand side and begins at position 1. Hence bit 24-28 is the “B”. 

21.5  Operators and reserved words 

21.5.1 Operators 

The following operators are valid in “if” statements: 

Operator Meaning Valid types on the right side of operator 
= Equality Strings, integers and real numbers 
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<> Inequality Strings, integers and real numbers 
<= Greater or equal Integers and real numbers 
>= Less or equal Integers and real numbers 
< Less than Integers and real numbers 
> Greater than Integers and real numbers 

 

The left side of an operator must be a field. 

21.5.2 Reserved words 

 

Reserved word Meaning 

Print Sets the result of a text based object. 

Search for Identifies the NMEA sentence the decoder  is valid for 

If Beginning of an “if” statement. “if” statement cannot be nested. 

EndIf Identifies that the “if” statement ends here 

Stop Stops the program return result 

Break Cancels the program return with no result 

Value Sets the result of a number based object (e.g. a gauge). 

Trend Alternative keyword for Value. Trend should not be used in new 

decoders and is kept for backwards compatibility only. 

Add(Field1, Field2) Adds two fields to each other ( Field1 + Field2 ) and returns the 

result 

Sub(Field1, Field2) Subtracts the two fields from each other ( Field1 - Field2 ) and 

returns the result. 

Bit(Field, Bit no.) Returns 1 if a bit is set in Field, 0 if not. Field must be a hex string. 

If bit does not exist, it returns –1. 

Cbit(Field, Bit no.)  Returns 1 if a bit is set in Field, 0 if not. Field must be a character 

and Cbit checks the binary representation of the character's ASCII 

value. Range may be used to select the specific character. Please 

refer to "Range and Format Specifiers" below for more information. 

Only the leftmost character is used if the field or range contains 

multiple characters. Bit no. must have a value of 1 through 8.  

  

Example: 

  

Assume that field #1 has the value "ABC". 
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Cbit(#1, 1) will then be "1" as the character "A" has the ASCII 

value 65 (decimal) = 01000001 (binary) whose bit number 1 

(rightmost or least significant bit) is "1".  

Dbit(Field, Bit no.)  Returns 1 if a bit is set in Field, 0 if not. Field must be a decimal 

value between 0 and 9999999999. Bit no. must have a value of 1 

through 34.  

Cmask(Field, Mask)  Applies a binary mask to the ASCII value of a character in Field. 

The result is a value between 0 and 255. Range may be used to 

select the specific character. Please refer to "Range and Format 

Specifiers" below for more information. Only the leftmost character 

is used if the field or range contains multiple characters. Mask must 

have a value between 0 to 255.  

  

Example: 

  

Assume that field #1 has the value "ABC". 

Cmask(#1, 192) will then be "64" as the character "A" has the 

ASCII value 65 (decimal) = 01000001 (binary) and when applying 

a mask of 192 (decimal) = 11000000 (binary) the result is 

01000000 (binary) = 64 (decimal).  

Mbit(Field, bit no.) Returns 1 if a bit is set in a Modbus field, 0 if not. Field must be a 

Modbus string. If bit does not exist, it returns –1. 

Mreg(Field, Reg no. [, Factor [, 

Offset]]) 

 

Returns Modbus register if the register exists in the Modbus field. 

Field must be a Modbus string. If the register does not exists it 

returns –1. 

  

Specifying Factor and Offset can be used to return the following 

calculation: 

  

Factor * ( Modbus register + Offset ) 

  

Specifying Factor and Offset is optional. If omitted a default value 

of 1 is used for Factor and 0 is used for Offset. 

MregBit(Field, reg no., bit no) 

Returns the value of a bit in a Modbus register if the register exists 

in the Modbus field. Field must be a Modbus string. If register does 

not exist, it returns –1. Generates a compile-time error if bit no. is 

not within 0..15 

Msreg(Field, Reg no. [, Factor 

[, Offset]]) 

Returns a signed Modbus register if the register exists in the 

Modbus field. Field must be a Modbus string. If register does not 

exists it returns 0. 

  

Specifying Factor and Offset can be used to return the following 
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calculation: 

  

Factor * ( Modbus register + Offset ) 

  

Specifying Factor and Offset is optional. If omitted a default value 

of 1 is used for Factor and 0 is used for Offset. 

  

Use Mreg to check for the register existence. 

Mdwreg(Field, Reg no. [, Byte 

order [, Factor [, Offset]]]) 

Converts the double word starting at Reg no. to an unsigned double 

word. 

  

Input: 

Field: Indicating NMEA string field number (usually 2). 

Reg no.: Number of first register to convert. 

Byte order: Byte ordering performed before conversion (described 

below). 

Factor: Factor for calculation (Same as for Mreg). 

Offset: Offset for calculation (Same as for Mreg). 

  

Returns: 

Reg no. and Reg no. + 1 converted to unsigned double word 

according to Byte order. 

Return value is -1 if Reg no. and Reg no. + 1 does not exist. 

Msdwreg(Field, Reg no. [, 

Byte order [, Factor [, 

Offset]]]) 

Converts the double word starting at Reg no. to a signed double 

word. 

  

Input: 

Field: Indicating NMEA string field number (usually 2). 

Reg no.: Number of first register to convert. 

Byte order: Byte ordering performed before conversion (described 

below). 

Factor: Factor for calculation (Same as for Mreg). 

Offset: Offset for calculation (Same as for Mreg). 

  

Returns: 

Reg no. and Reg no. + 1 converted to signed double word according 

to Byte order. 

Return value is undefined if Mdwreg(Field, Reg no.) < 0. 

Mdwfreg(Field, Reg no. [, 

Encoding]) 

Converts the double word starting at Reg no. to a floating point. 

  

Input: 

Field: Indicating NMEA string field number (usually 2). 

Reg no.: Number of first register to convert. 

Encoding: Encoding used for conversion (described below). 
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Returns: 

Reg no. and Reg no. + 1 converted to floating point according to 

Encoding. 

Return value is undefined if Mdwreg(Field, Reg no.) < 0. 

DETime(Field)  

Returns a double encoded timestamp in Field converted to the 

format "YYYY-MM-DD hh:mm:ss". Double encoded timestamps 

are used by e.g. Martec. 

HexDec(Field)  

Returns a hexadecimal number in Field as decimal. A maximum of 

8 hexadecimal characters can be converted. Refer to [range] in the 

section "The NMEA field Identifier" below to convert a part of a 

field. 

Find(Index, First Field, 

Modulus, Reference String [, 

First Character] ) 

This function compares a Reference String with the data in specific 

fields in a sentence. 

The return value is 1 if a match is found and 0 if not. If a match is 

found the position of the matching field is stored in Index. 

First Field: The position of the first data field to be checked. 

Modulus: The offset to the next data field to be checked. 

First Character: First character in the specified data fields to be 

compared with the first character in "Reference String" (from left). 

Specifying "First Character" is optional - if omitted a default value 

of 1 is used. 

(A "null" Reference String matches the contents of any field. The 

command Find(%Index_id, n, 1, "") can therefore be used to 

check whether field "n" exists in a sentence.) 

  

Example: 

  

$BWDXDR,S,0,,WD.4.13,S,1,,WD.4.12*76 

  
Print Find(%6, 5, 4, ".4.12", 3) 

  

Looks for ".4.12" starting from data field #5 and then every 4th data 

field. The comparison with the "Reference String" starts at the 3rd 

character in each field. 

The result is that "9" is stored in index number 6 and "1" is printed 

because the "Find" succeeded. 

Please refer to the section "The Index Identifier" below for more 

information. 

FieldAt(Index [, Offset] ) 

Returns the value of a field relative to the field referenced by Index. 

The Offset can be both negative and positive in order to specify a 

field respectively before and after the field referenced by Index. 

Specifying Offset is optional. A default value of 0 is used if Offset 

is omitted, effectively returning the value of the field referenced by 

Index. 
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The function generates a runtime error if the number stored in Index 

plus Offset points to a non-existing field. 

Please refer to the section "The Index Identifier" below for more 

information. 

Calc(Index, Factor, Offset) 
Performs a calculation on the value of a field and returns the result. 

The performed calculation is: Factor * ( Fieldvalue + Offset ) 

Last(Field, Count) Returns the last n characters of a field, where n = count 

  

21.5.2.1 Encoding and byte order for Mdwreg, Msdwreg, Mdwfreg 

Encoding: 

0: IEEE - No Swapping ("ABCD" => "ABCD") before conversion (default) 

1: IEEE - Byte Swapping ("ABCD" => "BADC") before conversion 

2: IEEE - Word Swapping ("ABCD" => "CDAB") before conversion 

3: IEEE - Byte and Word Swapping ("ABCD" => "DCBA") before conversion 

 

  

Byte order: 

0: No Swapping ("ABCD" => "ABCD") before conversion (default) 

1: Byte Swapping ("ABCD" => "BADC") before conversion 

2: Word Swapping ("ABCD" => "CDAB") before conversion 

3: Byte and Word Swapping ("ABCD" => "DCBA") before conversion 

21.6 Field Identifier 

The hash mark “#” indicates a field identifier: 

#field [range] [format] 

Where “field” indicates the field number beginning from 1. 

The “range” is optional and identifies the range of characters to use. The syntax is “x:y” where “x” 

is the first character to use (unless “y” is negative) and “y” is the number of characters. If  “x” is out 

of range then the program is terminated and an error is printed. If “y” is out of range then the 

program will print to the end of the field. 

If  “y” is negative then the characters are selected from left. First to be printed is “x-y+1” and last 

character to be printer is “x” 

Example: 

 
Field no: |  1  |    2     |3| 4 

Sentence: $XXYYY,123456,N,A*1B 

 

search for "YYY" 

 

print #2 3:-2 
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The printed result will be “23”. 

 

If  “x” is negative then the first character to print is selected from the right. Example: 

 
Field no: |  1  |    2     |3| 4 

Sentence: $XXYYY,123456,N,A*1B 

 

search for "YYY" 

 

print #2 -4:3 

 

This printed result will be “345”. 

 

To print everything but the last two characters of field 2: 

 
Field no: |  1  |    2     |3| 4 

Sentence: $XXYYY,123456,N,A*1B 

 

search for "YYY" 

 

print #2 -3:-99 

 

Will print “1234” 

The “format” field is optional and similar to the one used in Visual Basic. The maximum length of 

a formatter is limited to 10 characters, including the decimal point. 

E.g.: 

 

Formatter Data to display    

- 14.75 0.336 -17 278 

F0 14 0 -17 278 

F00.00 14.75 00.34 -17.00 278.00 

F0.000 14.750 0.336 -17.000 278.000 

F000.0 014.8 000.3 -017.0 278.0 

A000.0 014.8 000.3 017.0 278.0 

N000.0 -014.8 -000.3 017.0 -278.0 

By replacing the “F” with an “A” the result will be formatted into an absolute value. The following 

syntaxes are not allowed: “F0.” and “F.0” 

21.7 The Index Identifier 

  

The percentage sign “%” indicates an index identifier: 

  
%Index_id 
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where "Index_id" is a number between 1 and 9.  

  

An Index is used by the "Find command" to store a pointer/reference to a field in a sentence. 

%Index_id may be used as parameter for If, Print, Trend and Value commands (the value is a 

reference (number) to a field in a sentence). 

Use the FieldAt command to get the value (content) of the field referenced by an index.  

  

Examples:  

  

$BWDXDR,S,0,,WD.4.13,S,1,,WD.4.12*76  

  
Find(%2, 5, 4, "WD.4.12")    // Stores "9" in index number 2 ("%2")  

Print %2                     // Prints "9" (the field number found above)  

Print FieldAt(%2)            // Prints "WD.4.12" (the value of field number 9)  

Print FieldAt(%2, -2)        // Prints "1" (the value of field number 9 + (-2) = 

7)  

  

$PSM1,KA,DO06115,DO04411,9E  

  
Find(%5, 3, 1, "06115", 3)   // Stores "3" in index number 5 ("%5")  

Print %5                     // Prints "3" (the field number found above)  

Print FieldAt(%5)            // Prints "DO06115" (the value of field number 3)  

Print FieldAt(%5, 1)         // Prints "DO04411" (the value of field number 3 + 

1 = 4)  

 

21.8 Strings 

Strings must be enclosed in quotes. If a string contains quotes itself, then these quotes must be 

prefixed with a backslash ("\"). 

  

Example: 

  

$PSM1,KA,En33022S,En"DET-33.022.T,Fn61051,E7 

  
If #4 = "En\"DET-33.022.T" 

   Print "Ok!" 

Endif 
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21.9  Decoding of Modbus 

The VDR is able to record Modbus communication (this requires VDR software version 2.05 or 

newer). 

The VDR can operate as Modbus slave or master. The format of the data and the corresponding 

decoders depend on this. 

 

The Modbus data will be encapsulated as NMEA strings before they are stored by the VDR. 

The sentence formatter is: PMTM<PDU main group><Master flag> 

 

PMTM: Common prefix for all NMEA strings related to Modbus encapsulation 

PDU group: Modbus defines a number of different commands for read/write of bits and registers.  

 These have been compiled into four groups: 

 RDB:  Read bit 

 WRB:  Write bit 

 RDR:  Read Register 

 WRR Write Register 

Master flag: Sentence formatter is terminated by “M” if the string contains data sent to the master; 

i.e. the NMEA string contains a Modbus response 

 

 

21.9.1 Data format for VDR configured as Modbus slave 

The control system (master) sends data to the VDR on a regular basis. Both requests from and 

answers to the control system will be recorded by the VDR.  The requests from the control system 

contain the data of interest, while the answers to the control system are informational only. 

The control system will in this case use different forms of Modbus write commands; i.e. the decoder 

scripts must search for PMTMWRB and PMTMWRR 

Do not make scripts for the responses to the control system if the VDR is configured as Modbus 

slave; i.e. do not search for sentence formatter terminated with an “M” 
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Function code Sentence 

formatter for 

Master request 

Sentence 

formatter for 

Response  

from VDR  

Modbus 

Request 

Format 

Modbus 

Response 

Format 

Recorded 

response 

0x01: READ 

COILS 

RDB RDBM 2: Address 

2: #Coils 

1: #Bytes, N 

N: Data 

2: Address 

2: #Coils 

1: #Bytes, N 

N: Data 

0x02: READ 

DISCRETE 

IMPUTS 

as above as above as above as above as above 

0x03: READ 

HOLDING 

REGISTERS 

RDR RDRM 2: Address 

2: #Reg. 

1: #Bytes, N 

N: Data 

2: Address 

2: #Reg. 

1: #Bytes, N 

N: Data 

0x04: READ 

INPUT 

REGISTERS 

as above as above as above as above as above 

0x05: WRITE 

SINGLE COIL 

WRB WRBM 2: Address 

2: Data 

2: Address 

2: Data 

2: Address 

2: Data 

0x06: WRITE 

SINGLE 

REGISTER 

WRR WRRM as above as above as above 

0x07, 0x08, 

0x0B, 0x0C, 

0x11, 0x2B: 

Various 

diagnostics 

DIA DIAM   As received 

Not decodable 

by Player 

0x0F: WRITE 

MULTIPLE 

COILS 

WRB WRBM 2: Address 

2: #Coils 

1: #Bytes, N 

N: Data 

2: Address 

2: #Coils 

2: Address 

2: #Coils 

 

0x10: WRITE 

MULTIPLE 

REGISTERS 

WRR WRRM 2: Address 

2: #Reg. 

1: #Bytes, N 

N: Data 

2: Address 

2: #Reg. 

2: Address 

2: #Reg. 

 

0x17: 

READ/WRIT

E MULTIPLE 

REGISTERS 

WRR RDRM 2: Read Addr 

2: #Read reg. 

2: Write Addr 

2: #Write reg. 

1: #Bytes, M 

M: Write Data 

1: #Bytes, N 

N: Read Data 

2: Read Addr 

2: #Read reg. 

1: #Bytes, N 

N: Read data 

OTHERS 

EXCEPTION 

OTH 

EXP 

OTHM 

EXCM 

  As received 

Not decodable 

by Player 
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21.9.2 Data format for VDR configured as Modbus master 

The VDR polls the control system (slave) on a regular basis. Both requests to and answers from the 

control system will be recorded by the VDR.  The answers from the control system contain the data 

of interest, while the requests to the control system are informational only.  

The control system will in this case respond to different forms of Modbus read request; i.e. the 

decoder scripts must search for PMTMRDBM and PMTMRDRM 

Do not make scripts for the request to the control system if the VDR is configured as Modbus 

master; i.e. search only for sentence formatter terminated with an “M”. 

 

Function code Sentence 

formatter for 

VDR Master 

request 

Sentence 

formatter for 

Response to 

VDR Master 

Modbus 

Request 

Format 

Modbus 

Response 

Format 

Recorded 

response 

0x01: READ 

COILS 

RDB RDBM 2: Address 

2: #Coils 

1: #Bytes, N 

N: Data 

2: Address 

2: #Coils 

1: #Bytes, N 

N: Data 

0x02: READ 

DISCRETE 

IMPUTS 

as above as above as above as above as above 

0x03: READ 

HOLDING 

REGISTERS 

RDR RDRM 2: Address 

2: #Reg. 

1: #Bytes, N 

N: Data 

2: Address 

2: #Reg. 

1: #Bytes, N 

N: Data 

0x04: READ 

INPUT 

REGISTERS 

as above as above as above as above as above 

 

21.9.3 Modbus functions 

These functions are only relevant when decoding Modbus data. 

 

 

MBIT( #<field no.> , <bit no.> ) 

 

Field number:  Always equal to 2 with the current encoding 

Bit no.: 0x01 to 0x10000 

 

Purpose: Used for testing the value for a bit in a “write multiple/single coils” command PDU. 

Returns 1 if the bit is 1 

Returns 0 if the bit is 0 

Returns -1 if the bit is not present.   

 

Used as a function in IF and PRINT statements: 

 

SEARCH FOR “PMTMWRB” //(or “PMTMRDBM” if VDR is master) 
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IF MBIT(#2,0x0021) < 0 

  // No bit so break without result 

  BREAK 

ENDIF 

 

IF MBIT(#2, 0x0021) = 0 

  PRINT “off” 

  TREND 0 

ENDIF 

 

IF MBIT(#2, 0x0021) = 1 

  PRINT “on” 

  TREND 1 

ENDIF 

 

 

Used on the following Modbus sentence: 

 

Multiple Coil (write) : $PMTMWRB,010F002000100255551A2F,A*70 

 

Gives the result “on” and trend “1”. 

  

Description:  

The specified field must contain a complete Modbus command coded as ASCII characters. 

- The function code must be equal to “0F”, “05”, “01”, “02” (character 3:2). 

 

Read or Write single bit: 

The address for the bit must match the “output address”, character 5:4. 

 

Read or Write multiple bits: 

- The bit must be within the addressed range; i.e. “starting address” to (“starting address” + 

“quantity of outputs” –1). “Starting address” is character 5:4 and  “quantity of outputs” is character 

9:4 

 

MREGBIT(#<field no.>,<register no.>,<bit no.>) 

  
Used as an operator in IF and PRINT statements. 

 

Field number: Always equal to 2 with the current encoding. 

Register no.: 0x01 to 0x10000 

Bit no.: 0 to 15 

  

Purpose: Used for reading one bit in a register from a write multiple/single register command PDU. 

Returns the value of the bit in the register if present in the PDU 

Returns –1 if the register value is not present 

Generates a compile-time error if bit no. is not within 0 to 15 

 

MREG(#<field no.>,<register no.>) 

 

Purpose: Used for reading a register from a read/write multiple/single register command PDU. 
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Returns the value from the register if present in the PDU 

Returns –1 if the register value is not present 

 

Used as a function in PRINT and IF statements: 

  

SEARCH FOR “PMTMWRR” //(or “PMTMRDRM” if VDR is master) 

 

IF MREG(#2,0x9c42) < 0 

  // No register so break without result 

  BREAK 

ENDIF 

 

PRINT “Register : ” MREG(#2, 0x9c42) 

TREND MREG(#2, 0x9c42) 

 

Used on the following Modbus sentence: 

 

Multiple Reg (write) : $PMTMWRR,01109C410003061111222233337616,A*6E 

 

Gives the result “Register : 4369” and trend “4369”. ( 4369 = 0x1111). 

 

Description:  

The specified field must contain a complete Modbus command coded as ASCII HEX. 

- The function code must be equal to “06”, “10”, “17”, “03” or “04” (character 3:2). 

 

Read or Write register: 

The address for the specified register must match the “register address”, character 5:4. 

 

Read or Write multiple registers: 

- The specified register must be within the addressed range; i.e. “starting address” to (“starting 

address” + “quantity of registers” –1). “Starting address” is character 5:4 and “quantity of registers” 

is character 9:4 

 

Read/write multiple registers (0x17): 

- The specified register must be within the addressed range; i.e. “starting address” to (“starting 

address” + “quantity of registers” –1). “Starting address” is character 13:4 and “quantity of 

registers” is character 17:4 

 

MSREG(#<field no.>,<register no.>) 

 

Purpose: Used for reading a register from a write multiple/single register command PDU. The 

MSREG function returns a signed value (two’s complement) while MREG returns the binary value. 

Returns the value from the register if present in the PDU. 

Returns 0 if the register value is not present or if the value is 0. Use MREG to test for register 

existence. 

 

Used as a function in PRINT and IF statements: 

  

SEARCH FOR “PMTMWRR” //(or “PMTMRDRM” if VDR is master) 
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IF MREG(#2,0x9c42) < 0 

  // No register so break without result 

  BREAK 

ENDIF 

 

PRINT “Register : ” MSREG(#2, 0x9c42) 

TREND MSREG(#2, 0x9c42) 

 

Used on the following Modbus sentence: 

 

Multiple Reg (write) : $PMTMWRR,01109C41000306FFFF222233337616,A*6E 

 

Gives the result “Register : -1” and trend “-1”. ( -1 = 0xFFFF). 

 

Description:  See description for MREG 

 

21.9.4 Overlap between input/holding registers and coils/discrete input 

It is not possible to distinguish between input/holding registers and coils/discrete input just using 

the sentence formatter. The Modbus function code must be decoded for a system that has address 

overlap for the input/holding registers or coils/discrete input. (This problem is only relevant if the 

VDR is configured as master) 

 

SSEARCH FOR "PMTMRDRM"  

IF MREG(#2,0x9c42) < 0 

  // No register so break without result 

  BREAK 

ENDIF 

IF #2 3:2 <> "04"  // Test for read of input registers 

  // This is not a read of input register so break without result 

  BREAK  

ENDIF 

 

PRINT "Register : " MREG(#2, 0x9c42) 

TREND MREG(#2, 0x9c42) 

 

 

21.10 Other functions 

21.10.1 Last function 

 

The last function returns the last characters of a field. 

The following fictive NMEA sentence is used: 

Field no: |  1  |    2     |3| 4 

Sentence: $XXYYY,DEADBEEF01,N,A*1B 
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search for "YYY" 

 

if last(#2,3) = “F01” 

    print last(#2,3) 

 trend last(#2,1) 

    stop 

endif 

 

 

The printed result will be “F01” and the trend value 1. 
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22  Creation of data processor configurations for the VRI 
The VDR Explorer may be used for creating data processor configuration for the VRI. A data 

processor is an application in the VRI which is able to send telemetry reports to servers on shore 

and on board the vessel. 

 

For a detailed description on how to configure a data processor, see MAN11841 “Manual for 

Installation manual for Vessel Remote Management, VRI 002”. 

 

The parameters for data to be included in telemetry report must be configured on the Telemetry tab  

 

 
 

Tag ID:  

Each data item must be given a unique tag which will be used as ID in the telemetry reports. 

 

Group: 
The “Tag IDs” may be organized in groups. 

 

Reports: 
When a tag is assigned to a report the name of the report will appear in this window. 

 

Aggregations: 
The VRI may perform calculations on the data. Note that a report contains values which are 

sampled over some time, for example 5 minutes. So in addition to sending the last sampled value, 

mean, deviation etc. is typically useful.  



User Manual for VDR Explorer for DM100/DM200/DM300 S-VDR and DM100/DM400/DM500 VDR 

Danelec Marine A/S 

 

9200294-34  Page 104/108 

 

22.1 Destination for report 

Go to Report->Destinations 

 
 

This is a list of possible destinations for reports. The parameters for a destination are configured in 

the VRI(s), for example the name and IP address. Common references (names) to the destinations 

between the VDR Explorer and the VRI(s) are necessary. The list in the VDR Explorer must be 

populated manually. 
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22.2 Creating of data processor configurations 

In the VDR Explorer, go to “Reports -> Reports” and configure the main parameters for a data 

processor. 

 
Click on “New report” to create a report configuration. 
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The content of the report and the transmission interval may be configured here. 

 

For details, see MAN11841 “Manual for Installation manual for Vessel Remote Management, VRI 

002”. 
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Appendix A: DM100 VDR/S-VDR conning display default 
configuration 
 
Object Title and 

Indicator 

Input Enabled/ 

Disabled 

Pre-configured 

decoder script 

Alternative Decoder 

scripts 

Numeric data 

display, left 

UTC Time 

Object 1 

SI04 Enabled UTC time (ZDA) UTC time (GGA) 

UTC time (GLL) 

UTC time (GNS) 

UTC time (RMC) 

UTC Date 

Object 2 

SI04 Enabled UTC date (ZDA) Date (RMC) 

Quality ind. 

Object 3 

SI04 Enabled Quality Indicator 

(GGA) 

 

Numeric data 

display, right 

Latitude 

Object 1 

SI04 Enabled Latitude (GLL) Latitude (GGA) 

Latitude (GNS) 

Latitude (RMC) 

Longitude 

Object 2 

SI04 Enabled Longitude (GLL) Longitude (GGA) 

Longitude (GNS) 

Longitude (RMC) 

COG 

Object 3 

SI04 Enabled COG true (VTG) COG (RMC) 

Doppler log 

indicator 

n/a 

Longitudinal speed 

SI05 Enabled STW (VHW) STW Longitudinal 

(VBW) 

n/a 

Bow transverse speed 

SI05 Disabled STW transverse 

(VBW) 

 

n/a 

Stern transverse speed 

SI05 Disabled Stern transv STW 

(VBW) 

 

n/a 

Relative wind 

SI07 Enabled Wind direction rel 

(MWV) 

 

Dual dial meter SOG 

Dial Meter 1 

Primary 

SI04 Enabled Speed (VTG) Speed (RMC) 

SOG Longitudinal 

(VBW) 

STW 

Dial Meter 2 

Primary 

SI05 Enabled STW (VHW) STW Longitudinal 

(VBW) 

Horizontal ruler R.O.T. 

Primary 

SI06 Enabled Rate of turn (ROT)  

Compass dial Heading 

Primary 

SI06 Enabled Heading true (HDT)  

Anemometer 

Graph 

 

Wind speed r 

Primary 

SI07 Enabled Wind speed rel kt 

(MWV) note 1 

 

Wind dir r 

Secondary 

SI07 Enabled Wind direction rel 

(MWV) 

 

Echo sounder 

Graph 

Depth 

Primary 

SI08 Enabled Depth (DPT)  

Range 

Secondary 

SI08 Disabled Range (DPT)  

Note 1) Decoders for other measuring units are available in the library. 
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Appendix B: VDR Explorer functional modes 
The VDR Explorer may be started in three different modes. Links to the all three mode exist in the 

“VDR Explorer” folder under “All Programs” for the PC. 

 

 

VDR Explorer (normal mode): 

All functionality is enabled. The PC user must have administrator rights. 

 

VDR Explorer – No admin rights: 

All functionality is enabled except for that it is not possible to access a capsule or a backup media 

directly. 

 

VDR Explorer – Safe Mode: 

Most functionality is disabled except for that it is possible replay recorded data. 
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